Ghostwire

CVE-2026-114422: The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored...

HIGH CVSS 0.0 EPSS 0.82%

Published: October 30, 2026 | Last Modified: October 30, 2026

Description

The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4.

Ghostwire Analysis — What This Means Practically

Exploitation Probability (EPSS): Low — 0.82% (57th percentile)

Low exploitation probability based on current threat landscape data. Standard patching timeline is appropriate.

This analysis is generated by Ghostwire from NVD, CISA KEV, EPSS, and open-source intelligence data. Verify findings through primary sources before acting.

Security Coverage (1 articles)

References